PAT 2019甲级春季考试真题2 Anniversary

发布于 / PAT-甲级 / 0 条评论

Zhejiang University is about to celebrate her 122th anniversary in 2019. To prepare for the celebration, the alumni association (校友会) has gathered the ID's of all her alumni. Now your job is to write a program to count the number of alumni among all the people who come to the celebration.

Input Specification:

Each input file contains one test case. For each case, the first part is about the information of all the alumni. Given in the first line is a positive integer N (105). Then N lines follow, each contains an ID number of an alumnus. An ID number is a string of 18 digits or the letter X. It is guaranteed that all the ID's are distinct.

The next part gives the information of all the people who come to the celebration. Again given in the first line is a positive integer M (105). Then M lines follow, each contains an ID number of a guest. It is guaranteed that all the ID's are distinct.

Output Specification:

First print in a line the number of alumni among all the people who come to the celebration. Then in the second line, print the ID of the oldest alumnus -- notice that the 7th - 14th digits of the ID gives one's birth date. If no alumnus comes, output the ID of the oldest guest instead. It is guaranteed that such an alumnus or guest is unique.

Sample Input:

5
372928196906118710
610481197806202213
440684198612150417
13072819571002001X
150702193604190912
6
530125197901260019
150702193604190912
220221196701020034
610481197806202213
440684198612150417
370205198709275042

Sample Output:

3
150702193604190912

题目大意:输入都是身份证。在第二个表里面计算有多少个在第一个表中出现了的人。最后输出年龄最大的人。

#include <bits/stdc++.h>
using namespace std;

int main(){
  set<string> alls;
  int icnt, qcnt;
  
  scanf("%d", &icnt);
  vector<string> allv(icnt);
  for(auto & it : allv){
    it.resize(20, '\0');
    scanf("%s", &it[0]);
    alls.insert(it);
  }
  
  int anscnt = 0;
  scanf("%d", &qcnt);
  vector<string> ojbk;
  for(int i = 0; i < qcnt; i++){
    string tmp(20, '\0');
    scanf("%s", &tmp[0]);
    ojbk.push_back(tmp);
    if(alls.find(tmp) != alls.end()){  //found
      anscnt++;
    }
  }
  sort(ojbk.begin(), ojbk.end(), [](string a, string b){
    return a.substr(6, 8) < b.substr(6, 8);
  });
  printf("%d\n%s\n", anscnt, ojbk[0].c_str());
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT 2019甲级春季考试真题2 Anniversary
目前还没有评论,快来抢沙发吧~