PAT-A 真题 – 1027 Colors in Mars

发布于 / PAT-甲级 / 0 条评论

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input

15 43 71

Sample Output

#123456

题目大意:将输入的三个10进制数字转化成13进制数字。并在前面加上个#

这道题转化后都是二位数,所以只用原来的数字除以13,得到十位数,再对13取余数,得到个位数,然后根据0123456879ABC的规则转化成十三进制的数字即可。

代码:

#include <iostream>
using namespace std;

int main(){
  char table[] = {'0', '1', '2', '3', '4', '5', '6', '7', '8', '9', 'A', 'B', 'C'};
  cout << '#';
  for(int i = 0; i < 3; i++){
    int a;
    cin >> a;
    cout << table[a/13] << table[a%13];
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1027 Colors in Mars
目前还没有评论,快来抢沙发吧~