PAT-A 真题 – 1050 String Subtraction

发布于 / PAT-甲级 / 0 条评论

Given two strings S1 and S2S=S1S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题目大意:第一行给定原文字,第二行给定要去除的字符集合,要求找到原文字中第二行出现的字符,并去除。

注意:输入可能有空格,请使用getline。

暴力会超时,最好的办法是遍历第二行字符串,把出现的字符的ASCII码对应数组的下标标记为1,然后输出的同时判断即可。

#include <iostream>
#include <algorithm>
#include <string>
using namespace std;

int main(){
  string str, rm;
  int ASCII[129] = {0};
  getline(cin, str);
  getline(cin, rm);
  for(int i = 0; i < rm.length(); i++){
    ASCII[ rm[i] ] = 1;
  }
  for(int i = 0; i < str.length(); i++){
    if(ASCII[str[i]]) continue;
    cout << str[i];
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1050 String Subtraction
目前还没有评论,快来抢沙发吧~