PAT-A 真题 – 1047 Student List for Course

发布于 / PAT-甲级 / 0 条评论

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (40,000), the total number of students, and K (2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题目大意:给定每门课有哪些同学选了,然后输出所有同学选的课程,按照字母序排序。

这道题和https://www.mmuaa.com/post/8f406d036174b126.html有异曲同工之妙。。。只不过是反过来了,不需要使用hash函数,直接存字符串就好了。

注意:

不能使用string,否则直接超时。不能使用cin和cout,否则也会超时,这道题的数据量很大。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <cstring>
using namespace std;

bool cmp(char *a, char *b){
  return strcmp(a, b) < 0;
}

int main(){
  int cou_cnt, stu_cnt;
  scanf("%d%d", &cou_cnt, &stu_cnt);
  vector<vector<char*> > T(stu_cnt + 1);  //存放表的容器 
  for(int i = 0; i < cou_cnt; i++){
    char* cou_name = new char[4];  //存放科目名称 
    scanf("%s", cou_name);
    int cnt, tmp;
    scanf("%d", &cnt);
    for(int j = 0; j < cnt; j++){
      scanf("%d", &tmp);
      T[tmp].push_back(cou_name);
    }
  }
  for(int i = 1; i <= stu_cnt; i++){
    printf("%d %d\n", i, T[i].size());
    sort(T[i].begin(), T[i].end(), cmp);
    for(auto j : T[i])
      printf("%s\n", j);
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1047 Student List for Course
目前还没有评论,快来抢沙发吧~