PAT-A 真题 – 1035 Password

发布于 / PAT-甲级 / 0 条评论

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

题目大意:

对于输入的密码,有些字符不是好辨认,所以就需要更换成易于识别的字符。

对于给定的密码,在密码中找到‘1’换成‘@’,0换成%,l换成大写L,O换成小写

如果没有需要换的,按照输出There are N accounts and no account is modified,如果N是1,不要写成复数形式。。。

代码:

#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
using namespace std;
typedef struct {
  string id, pw;
} stu;

string fuck(string s){
  for(int i = 0; i < s.length(); i++)
    switch(s[i]){
      case '1': s[i] = '@'; break;
      case '0': s[i] = '%'; break;
      case 'l': s[i] = 'L'; break;
      case 'O': s[i] = 'o'; break;
    }
  return s;
}

int main(){
  int cnt;
  cin >> cnt;
  vector<stu> V;
  for(int i = 0; i < cnt; i++){
    stu s;
    cin >> s.id >> s.pw;
    string _pw = fuck(s.pw);
    if(_pw != s.pw) V.push_back({s.id, _pw});
  }
  if(V.size()){
    cout << V.size() << endl;
    for(auto i : V)
      cout << i.id << ' ' << i.pw << endl;
  }else{
    if(cnt == 1) cout << "There is 1 account and no account is modified" << endl;
    else cout << "There are " << cnt << " accounts and no account is modified" << endl;
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1035 Password
目前还没有评论,快来抢沙发吧~