PAT-A 真题 – 1120 Friend Numbers

发布于 / PAT-甲级 / 0 条评论

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different frind ID's among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

题目大意:对于每一个数字,求出他们的每位数字相加之和,并排序去重输出。

排序去重,用set再好不过了~不会set的戳:https://www.mmuaa.com/post/b9a637bded62f2a6.html

#include <iostream>
#include <algorithm>
#include <set>
#include <string>
using namespace std;

int cal(int n){
  string s = to_string(n);
  int ans = 0;
  for(int i = 0; i < s.size(); i++)
    ans += s[i] - '0';
  return ans;
}

int main(){
  set<int> S;
  int cnt;
  cin >> cnt;
  for(int i = 0; i < cnt; i++){
    int n;
    cin >> n;
    S.insert(cal(n));
  }
  cout << S.size() << endl;
  set<int>::iterator it = S.begin();
  for(int i = 0; i < S.size(); i++, it++){
    if(i != 0) cout << ' ';
    cout << *it;
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1120 Friend Numbers
目前还没有评论,快来抢沙发吧~