PAT-A 真题 – 1139 First Contact

发布于 / PAT-甲级 / 0 条评论

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N  300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K ( 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

题目大意:比如a暗恋b,不会直接告白,而是a找到同性朋友lamp1(灯泡1),然后lamp1找到一个即是lamp1的朋友,又是b的朋友,而且与b同性的lamp2(灯泡2),然后才能告白。

给定关系网,以正代表男性,负代表女性,判断a暗恋b时,有几组可以帮助他们的方案。

注意这里可能有gay或者百合。

输出要按照顺序。

#include <bits/stdc++.h>
using namespace std;
unordered_map<int, bool> exist;
vector<int> G[10000];

typedef struct{
  int a, b;
} node;

int H(int a, int b){
  a = abs(a), b = abs(b);
  if(a > b) swap(a, b);
  return a * 10000 + b;
}

int main(){
  int vcnt, ecnt;
  cin >> vcnt >> ecnt;
  for(int i = 0; i < ecnt; i++){
    int a, b;
    cin >> a >> b;
    G[abs(a)].push_back(b);
    G[abs(b)].push_back(a);
    exist[H(a, b)] = true;
  }
  int qcnt;
  cin >> qcnt;
  for(int i = 0; i < qcnt; i++){
    int a, b;
    cin >> a >> b;  // a 暗恋 b 
    vector<node> ans;  //存放结果 
    for(auto lamp1 : G[abs(a)]){  //lamp1是a的朋友 
      //灯泡1的性别不能和 a 不同 
      if(lamp1 * a < 0) continue;
      //灯泡1不能是b或a 
      if(lamp1 == b || lamp1 == a) continue;
      for(auto lamp2 : G[abs(lamp1)]){
        //灯泡2的性别不能和 b 不同 
        if(lamp2 * b < 0) continue;
        //灯泡2不能是a或b或灯泡1 
        if(lamp2 == a || lamp2 == b || lamp2 == lamp1) continue; 
        //灯泡2必须和b是朋友
        if(exist[H(lamp2, b)])
          ans.push_back(node{abs(lamp1), abs(lamp2)});
      }
    }
    printf("%d\n", ans.size());
    sort(ans.begin(), ans.end(), [](node a, node b){
      if(a.a != b.a) return a.a < b.a;
      return a.b < b.b;
    });
    for(auto it : ans) printf("%04d %04d\n" ,it.a, it.b);
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1139 First Contact
目前还没有评论,快来抢沙发吧~