PAT-A 真题 – 1116 Come on! Let's C

发布于 / PAT-甲级 / 0 条评论

"Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

  • 0、 The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).

  • 1、 Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!

  • 2、 Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (104), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

题目大意:给定获奖名单,排名第一的礼物是Mystery Award,名次为质数的礼物是Minion,其他的人礼物是Chocolate,对于查询结果,输出其礼物名称。如果已经查询过了,输出Checked。

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;

bool isPrime(int n){
  if(n == 2) return true;
  for(int i = 2; i < n / 2; i++)
    if(n % i == 0) return false;
  return true;
}

int main(){
  string table[10010];
  int cnt;
  cin >> cnt;
  for(int i = 1; i <= cnt; i++){
    string award;
    if(i == 1) award = "Mystery Award";
    else if(isPrime(i)) award = "Minion";
    else award = "Chocolate";
    int id;
    cin >> id;
    table[id] = award;
  }
  cin >> cnt;
  for(int i = 0; i < cnt; i++){
    int id;
    cin >> id;
    printf("%04d: ", id);
    if(table[id] == "") cout << "Are you kidding?" << endl;
    else {
      cout << table[id] << endl;
      table[id] = "Checked";
    } 
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1116 Come on! Let's C
目前还没有评论,快来抢沙发吧~