PAT-A 真题- 1070. Mooncake

发布于 / PAT-甲级 / 0 条评论

原题干:

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

题目大意:计算月饼最大售价。使用了贪心算法,参考https://www.mmuaa.com/post-123.html

注意使用double类型存储库存量!注意使用double类型存储库存量!注意使用double类型存储库存量!

重要的事情说三遍。。。否则测试点2过不去的。。。原因大概和double计算精度有关?我猜的.....

代码:

#include <cstdio>
#include <algorithm>
using namespace std;
#define MAXN 1010

typedef struct {
    double amount; //数量
    double price;//单价
} node;

bool cmp(node a, node b){
    return a.price > b.price;
}

int main(){
    node cake[MAXN];
    int N;
    double D;
    scanf("%d %lf", &N, &D);
    for(int i = 0; i < N; i++)
        scanf("%lf", &cake[i].amount);   //读入数量
    for(int i = 0; i < N; i++){
        scanf("%lf", &cake[i].price);
        cake[i].price = cake[i].price /cake[i].amount;  //计算单价
    }
    sort(cake, cake + N, cmp);  //按照单价排序
    double ans = 0.0;
    for(int i = 0; i < N; i++){
        if(D == 0) break;
        if(D >= cake[i].amount){    //当前种类的月饼可以全部卖出
            ans += cake[i].price*cake[i].amount;
            D -= cake[i].amount;
        }else{                      //当前种类的月饼不能全部卖出
            ans += cake[i].price*D;
            D = 0;
        }
    }
    printf("%.2f", ans);
    return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题- 1070. Mooncake
目前还没有评论,快来抢沙发吧~