PAT-A 真题 – 1055 The World's Richest

发布于 / PAT-甲级 / 0 条评论

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (105) - the total number of people, and K (103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [106,106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (100) - the maximum number of outputs, and [AminAmax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [AminAmax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题目大意:给定输入个数和查询个数,输入每行给出姓名  年龄  家产。

对于每个查询,给出 最大输出个数M  年龄最小值Amin  年龄最大值Amax

要求按照规定顺序输出年龄在[Amin, Amax]的所有人的信息。如果人的个数超过M,输出M个。

规定的顺序是:家产大的在前面。如果家产相同,年龄小的在前面。如果年龄相同,按照名字的字典序排序。

这道题数据量比较大,防止超时我没有使用STL和cin/cout,甚至在查询的地方写个二分查找,但是发现线性查找就可以了,所以简化了代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;

struct node{
  char name[10];
  int age, worth;
} V[100010];

bool cmp(node a, node b){
  if(a.worth != b.worth) return a.worth > b.worth;
  if(a.age != b.age) return a.age < b.age;
  return strcmp(a.name, b.name) < 0;
}

int main(){
  int icnt, qcnt;
  scanf("%d %d", &icnt, &qcnt);
  for(int i = 0; i < icnt; i++)  //读取全部数据 
    scanf("%s %d %d", &(V[i].name), &(V[i].age), &(V[i].worth));
  sort(V, V + icnt, cmp);  //执行排序 
  for(int i = 1; i <= qcnt; i++){  //读取并执行查询 
    printf("Case #%d:\n", i);
    int M, Amin, Amax, outcnt = 0;
    scanf("%d %d %d", &M, &Amin, &Amax);
    for(int i = 0; i < icnt; i++){
      if(outcnt >= M) break;  //输出够了,break 
      if(V[i].age >= Amin && V[i].age <= Amax){
        outcnt++;    //累加输出次数 
        printf("%s %d %d\n", V[i].name, V[i].age, V[i].worth);
      }
    }
    if(!outcnt) printf("None\n");  //没有结果,输出None 
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1055 The World's Richest
目前还没有评论,快来抢沙发吧~