PAT-A 真题 – 1067 Sort with Swap(0, i)

发布于 / PAT-甲级 / 0 条评论

Given any permutation of the numbers {0, 1, 2,..., N1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (105) followed by a permutation sequence of {0, 1, ..., N1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

题目大意:第一行给定一个正整数N,接着给定一个长度为N的乱序序列,序列元素为0~N-1,现在进行排序,只允许0与其他数字进行交换,问最少多少次能把数列排序完毕。

这道题有两种情况,第一种情况,序列中第一个元素(即array[0])不是0,此时需要将0与第0所在的位置的元素(即a[i]与a[a[i]])交换即可。

第二种情况,序列中第一个元素是0,此时需要找到第一个位置i与该位置上的元素不相等的一项(即a[i] != i),与序列第一个元素交换即可。这里注意,不用每次都遍历一遍数组去找a[i] != i,接着上次遍历到的地方遍历即可(下面的代码加了static,就是这个目的),否则会有两个测试点超时

#include <bits/stdc++.h>
using namespace std;
vector<int> arr, pos(100010);
int swap_cnt = 0;
void _swap(int &a, int &b){
  swap_cnt++;
  swap(a, b);
}

bool Judge(){
  for(static int i = 0; i < arr.size(); i++){
    if(arr[i] != i){
      swap(pos[arr[0]], pos[arr[i]]);
      _swap(arr[0], arr[i]);
      return true;
    }
  }
  return false;
}

int main(){
  int cnt;
  scanf("%d", &cnt);
  arr.resize(cnt);
  for(int i = 0; i < cnt; i++){
    scanf("%d", &arr[i]);
    pos[arr[i]] = i;
  }
  while(arr[0] || Judge()){
    _swap(arr[pos[0]], arr[pos[pos[0]]]);
    swap(pos[0], pos[pos[0]]);
  }
  printf("%d\n", swap_cnt);
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1067 Sort with Swap(0, i)
目前还没有评论,快来抢沙发吧~