PAT-A 真题 – 1129 Recommendation System

发布于 / PAT-甲级 / 0 条评论

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N ( 50,000), the total number of queries, and K ( 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

题目大意:推荐系统。对于用户的每一个输入,给出相应的推荐,要求推荐用户查询次数最多的K个编号,如果查询次数相同,输出编号最小的。

这道题如果对每个查询直接sort,超时妥妥的,建议使用set,set内部采用红黑二叉树实现,效率比较高。

但是set无法实现sort像compare函数那样的效果,可以通过重载运算符来实现。

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

int freq[50010] = {0};

struct node{
  int id;
  bool friend operator < (const node &a, const node &b){
    if(freq[a.id] != freq[b.id])
      return freq[a.id] > freq[b.id];
    return a.id < b.id;
  }
};

int main(int argc, char **argv){
  int cnt, limit;
  cin >> cnt >> limit;
  set<node> S;
  for(int i = 0; i < cnt; i++){
    int n;
    cin >> n;
    if(i){
      cout << n << ":";
      set<node>::iterator it = S.begin();
      for(  int _i = 0;
          _i < limit && it != S.end();
          _i++, it++) cout << ' ' << it->id;
      cout << endl;
    }
    set<node>::iterator it = S.find({n});
    if(it != S.end()) S.erase(it);
    freq[n]++;
    S.insert({n});
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1129 Recommendation System
目前还没有评论,快来抢沙发吧~