PAT-A 真题 – 1109 Group Photo

发布于 / PAT-甲级 / 0 条评论

Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

  • The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;

  • All the people in the rear row must be no shorter than anyone standing in the front rows;

  • In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

  • In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

  • When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers N (104), the total number of people, and K (10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:

For each case, print the formation -- that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:

10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159

Sample Output:

Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John

题目大意:集体照。给出若干歌同学的姓名和身高,按照身高最高的在中间、左边的不能比右边的矮,后面的不能比前面的矮,多余的人放在最后一排 的原则,进行排队形。

这道题的思路是直接读入全部同学的信息,然后进行排序,排序后定义pos_it为中心,接着让pos_it = pos_it - 1、pos_it = pos_it + 2、pos_it = pos_it - 3.。。。。向数组下标为pos_it的位置存入数据,从后向前,每行一输出。

代码:

#include <cstdio>
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
typedef struct {
  int height;
  string name;
} node;

bool cmp(node a, node b){
  if(a.height != b.height) return a.height > b.height;
  return a.name < b.name;
}

int main(){
  int N, K;
  vector<node> stu;
  cin >> N >> K;
  int per_line = N / K;
  int last_line = per_line + (N - K * per_line);
  for(int i = 0; i < N; i++){
    node tmp;
    cin >> tmp.name >> tmp.height;
    stu.push_back(tmp);
  }
  sort(stu.begin(), stu.end(), cmp);
  int it = 0;  //当前正在排序的人 
  for(int i = 0; i < K; i++){
    int this_line = !i ? last_line : per_line;  //这一行有多少人 
    int pos_it = this_line / 2;  //中间位置的下标 
    vector<string> ans(N);  //存储这一行的容器 
    int direct = -1;
    while(pos_it >= 0 && pos_it < this_line){
      ans[pos_it] = stu[it++].name;
      pos_it += direct;
      if(direct < 0){
        direct *= -1;
        direct++;
      }else{
        direct *= -1;
        direct--;
      }
    }
    for(int j = 0; j < this_line; j++){
      cout << ans[j];
      if(j != this_line - 1) cout << ' ';
    }
    ans.clear();
    cout << endl;
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1109 Group Photo
目前还没有评论,快来抢沙发吧~