PAT-A 真题- 1032. Sharing

发布于 / PAT-甲级 / 0 条评论

题干:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.


Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

生词:

sublist : 子列表                suffix : 后缀

common : 普通的            represented : 代表

题目大意:

第一行给出两个首地址和节点个数,接下来给出两条链表,找出两条链表第一个公用节点的位置。

这道题使用链表做会麻烦些,我们可以牺牲内存,简化我们的代码,开一个100000大小的数组当做计算机内存,数组下标就是内存地址。

具体代码如下:

#include <iostream>
using namespace std;

typedef struct{
    char word;
    int next;
    bool flag;
} node;
node RAM[100000];
int main(){
    int head1, head2, cnt, addr;
    cin >> head1 >> head2 >> cnt;
    while(cnt--){
        cin >> addr;
        cin >> RAM[addr].word >> RAM[addr].next;
        RAM[addr].flag = false;
    }
    int same_addr = -1;
    while(head1 != -1){
        RAM[head1].flag = true;
        head1 = RAM[head1].next;
    }
    while(head2 != -1){
        if(RAM[head2].flag){
            same_addr = head2;
            break;
        }
        head2 = RAM[head2].next;
    }
    if(same_addr != -1) printf("%05d", same_addr);
    else printf("-1");
    return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题- 1032. Sharing
目前还没有评论,快来抢沙发吧~