PAT-A 真题 – 1038 Recover the Smallest Number

发布于 / PAT-甲级 / 0 条评论

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Do not output leading zeros.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

题目大意:

从给定数字中进行排序,找到排序后序列最小的一个并输出。

这是一个贪心算法类问题,最简单的排序算法就是直接用sort,cmp函数定义为将两个字符串分别正着拼接和反着拼接,比较大小。

代码如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <string>
#include <vector>
using namespace std; 

bool cmp(string a, string b){
  return a + b < b + a;
}

int main(){
  int n;
  cin >> n;
  vector<string> L(n);
  for(int i = 0; i < n; i++)
    cin >> L[i];
  sort(L.begin(), L.end(), cmp);
  string output;
  for(int i = 0; i < L.size(); i++){
    output += L[i];
  }
  int it;
  for(it = 0; output[it] == '0'; it++);
  if(it != output.size())
    for(; it < output.size(); it++)
      cout << output[it];
  else cout << 0;
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1038 Recover the Smallest Number
目前还没有评论,快来抢沙发吧~