PAT-A 真题- 1036. Boys vs Girls

发布于 / PAT-甲级 / 0 条评论

原题干:

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

题目大意:比较成绩信息。M表示♂,F表示♀。题目非常简单,就是一个简单的排序,不做解释了。

代码如下:

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

typedef struct{
    string name;
    string id;
    int grade;
} stu;

bool cmp_M(stu a, stu b){
    return a.grade < b.grade;
}

bool cmp_F(stu a, stu b){
    return a.grade > b.grade;
}

int main(){
    stu M[1000], F[1000], *p;
    int m_cnt = 0, f_cnt = 0, cnt;
    cin >> cnt;
    for(int i = 0; i < cnt; i++){
        string tmp_name;
        char sw;
        cin >> tmp_name >> sw;
        if(sw == 'M') p = M + (m_cnt++);
        else p = F + (f_cnt++);
        p->name = tmp_name;
        cin >> p->id >> p->grade;
    }
    bool absent = false;
    if(f_cnt){
        sort(F, F + f_cnt, cmp_F);
        cout << F[0].name << " " << F[0].id;
    }else cout << "Absent", absent = true;
    cout << endl;
    if(m_cnt){
        sort(M, M + m_cnt, cmp_M);
        cout << M[0].name << " " << M[0].id;
    }else cout << "Absent", absent = true;
    cout << endl;
    if(absent)
        cout << "NA" << endl;
    else cout << F[0].grade - M[0].grade << endl;
    return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题- 1036. Boys vs Girls
目前还没有评论,快来抢沙发吧~