PAT-A 真题 – 1153 Decode Registration Card of PAT

发布于 / PAT-甲级 / 0 条评论

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;

  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;

  • the 5th - 10th digits give the test date, in the form of yymmdd;

  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (104) and M (100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Termwill be the letter which specifies the level;

  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;

  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);

  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;

  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

题目大意:给出pat准考证号,按照要求排序输出。

这道题逻辑比较复杂,下面的代码预先算好了全部结果,对于查询,可以直接返回答案。其实每次查询的时候再计算结果也可以,但是会比较耗时。

#include <bits/stdc++.h>
using namespace std;

struct node{
  string card;
  int score;
  node(){
    card.resize(15, '\0');
  }
};

struct pair_node{
  int site, cnt;
};

bool cmp(node a, node b){
  if(a.score != b.score) return a.score > b.score;
  return a.card < b.card;
}

void output(vector<node> & V){
  if(V.size() == 0)
    printf("NA\n");
  else
    for(auto & i : V)
      printf("%s %d\n", i.card.c_str(), i.score);
}

int main(){
  int icnt, qcnt;
  scanf("%d %d", &icnt, &qcnt);
  int Site_Tester_Cnt[1000] = {0};  //下标:考场id, 值:人数
  int Site_Score[1000] = {0};      //下标:考场id, 值:总分 
  unordered_map<int, vector<int> > mp;//下标:时间,值:vector{考场id, 人数} 
  vector<node> A, B, T;
  //read data
  for(int i = 0; i < icnt; i++){
    node stu;
    scanf("%s %d", &stu.card[0], &stu.score);
    //save to vector 
    if(stu.card[0] == 'A') A.push_back(stu);
    else if(stu.card[0] == 'B') B.push_back(stu);
    else if(stu.card[0] == 'T') T.push_back(stu);
    //convert to int
    int date = stoi(stu.card.substr(4, 6));
    int site = stoi(stu.card.substr(1, 3));
    int id = stoi(stu.card.substr(10, 3));
    //cal
    Site_Tester_Cnt[site]++;
    Site_Score[site] += stu.score; 
    if(mp[date].size() == 0) mp[date].resize(1000, 0);
    mp[date][site]++;
  }
  //sort
  sort(A.begin(), A.end(), cmp); sort(B.begin(), B.end(), cmp); sort(T.begin(), T.end(), cmp);
  //read queries
  for(int i = 1; i <= qcnt; i++){
    int num;
    scanf("%d", &num);
    switch(num){
      case 1:  //output CardNum-Score, order by score, alphabetical 
        char c;
        scanf(" %c", &c);
        printf("Case %d: 1 %c\n", i, c);
        switch(c){
          case 'A':output(A);break;
          case 'B':output(B);break;
          case 'T':output(T);break;
        }
      break;
      case 2:  //output Testees_cnt-Total_score
        int site;
        scanf("%d", &site);
        printf("Case %d: 2 %03d\n", i, site);
        if(Site_Tester_Cnt[site])
          printf("%d %d\n", Site_Tester_Cnt[site], Site_Score[site]);
        else printf("NA\n");
      break;
      case 3:  //output Site-Site_Testtees_cnt
        int date;
        scanf("%d", &date);
        printf("Case %d: 3 %06d\n", i, date);
        vector<int> &_tmp = mp[date];
        if(_tmp.size()){
          unordered_map<int, int> _mp;
          for(int j = 0; j < _tmp.size(); j++)
            if(_tmp[j]) _mp[j] += _tmp[j];
          vector<pair_node> _V;
          for(auto it : _mp){
            pair_node shabi = {it.first, it.second};
            _V.push_back(shabi);
          }
          sort(_V.begin(), _V.end(), [](pair_node a, pair_node b){
            if(a.cnt != b.cnt) return a.cnt > b.cnt;
            return a.site < b.site;
          });
          for(auto it : _V){
            printf("%d %d\n", it.site, it.cnt);
          }
        }else
          printf("NA\n");
      break;
    }
  }
  return 0;
}

对于dev-cpp旧版本的g++编译器自带的头文件没有stoi函数,下面给出一个我自己写的stoi函数:(往pat平台上提交不允许有这一段)

int stoi(string n){
  int ans = 0;
  for(auto i : n){
    ans *= 10;
    ans += (i - '0');
  }
  return ans;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1153 Decode Registration Card of PAT
目前还没有评论,快来抢沙发吧~