数据结构与算法-7-25 朋友圈

发布于 / 刷题 / 0 条评论

某学校有N个学生,形成M个俱乐部。每个俱乐部里的学生有着一定相似的兴趣爱好,形成一个朋友圈。一个学生可以同时属于若干个不同的俱乐部。根据“我的朋友的朋友也是我的朋友”这个推论可以得出,如果A和B是朋友,且B和C是朋友,则A和C也是朋友。请编写程序计算最大朋友圈中有多少人。

输入格式:

输入的第一行包含两个正整数N(30000)和M(1000),分别代表学校的学生总数和俱乐部的个数。后面的M行每行按以下格式给出1个俱乐部的信息,其中学生从1~N编号:

第i个俱乐部的人数Mi(空格)学生1(空格)学生2 … 学生Mi

输出格式:

输出给出一个整数,表示在最大朋友圈中有多少人。

输入样例:

7 4
3 1 2 3
2 1 4
3 5 6 7
1 6

输出样例:

4

这是一个并查集问题,要注意必须按秩归并,否则最后一个测试点会超时。

#include <iostream>
#include <algorithm>
using namespace std;
#define MAXN 30010

int Find(int x, int *S){
    if(S[x] < 0) return x;
    else return S[x] = Find(S[x], S);
}

void Union(int root, int child, int *S){
    int root1 = Find(root, S);
    int root2 = Find(child, S);
    if(root1 == root2) return;
    else if(S[root1] < S[root2]){
        S[root2] += S[root1];
        S[root1] = root2;
    }
    else{
        S[root1] += S[root2];
        S[root2] = root1;
    }
}

int main(){
    int S[MAXN];
    fill(S, S + MAXN, -1);
    int N, M;
    cin >> N >> M;
    while(M--){
        int n, root;
        cin >> n >> root;
        for(int i = 1; i < n; i++){
            int child;
            cin >> child;
            Union(root, child, S);
        }
    }
    int min = 0x3fffffff;
    for(int i = 1; i <= N; i++){
        if(S[i] < min) min = S[i];
    }
    cout << -min << endl;
    return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » 数据结构与算法-7-25 朋友圈
目前还没有评论,快来抢沙发吧~