In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)
Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).
Output Specification:
For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either Eulerian
, Semi-Eulerian
, or Non-Eulerian
. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:
3 3 4 3 3
Non-Eulerian
题目大意:给定一个图,要求在第一行输出每个顶点的度,然后第二行输出是欧拉图还是半欧拉图还是非欧拉图。
欧拉图这个定义题目已经说的很清晰了,是离散数学的内容,有兴趣可以百度一下。
每个定点的度都是偶数的图是欧拉图,如果有两个点的度是奇数,其他都是偶数,则是半欧拉图。否则就不是欧拉图。
听起来是不是很简单~连邻接矩阵邻接表都不用建,记录一下度就好了,按照这种Simple的写法只能得20分,测试点3会boom。
因为,欧拉图的前提得是连通图呀。。。。。
所以你必须要用DFS或者BFS算法遍历一遍,看看是不是连通的。
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 510, inf = 0x7fffffff;
int G[maxn][maxn], PointCnt, EdgeCnt;
bool visited[maxn] = {false};
void DFS(int s){
for(int i = 1; i <= PointCnt; i++){
if(G[s][i] != inf && visited[i] == false){
visited[i] = true;
DFS(i);
}
}
}
bool DFSG(){
int cnt = 0; //记录有几个连通块
for(int i = 1; i <= PointCnt; i++){
if(visited[i] == false){
cnt++;
visited[i] = true;
DFS(i);
}
}
return cnt < 2; //大于等于两个,说明不连通
}
int main(){
fill(G[0], G[0] + maxn*maxn, inf);
int Deg[maxn] = {0};
cin >> PointCnt >> EdgeCnt;
for(int i = 0; i < EdgeCnt; i++){
int l, r;
cin >> l >> r;
Deg[l]++, Deg[r]++;
G[l][r] = G[r][l] = 0;
}
int cnt = 0;
for(int i = 1; i <= PointCnt; i++){
if(i > 1) cout << ' ';
cout << Deg[i];
if(Deg[i] % 2) cnt++; //记录有几个奇数度的点
}
if(!DFSG()) cout << endl << "Non-Eulerian" << endl;//不连通,输出no
else if(cnt == 0) cout << endl << "Eulerian" << endl;
else if(cnt == 2)
cout << endl << "Semi-Eulerian" << endl;
else cout << endl << "Non-Eulerian" << endl;
return 0;
}