PAT-A 真题 – 1128 N Queens Puzzle

发布于 / PAT-甲级 / 0 条评论

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1,Q2,,QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

8q.jpg 9q.jpg
Figure 1 Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K200). Then K lines follow, each gives a configuration in the format "N Q1 Q2 ... QN", where 4N1000 and it is guaranteed that 1QiN for all i=1,,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

题目大意:N皇后问题,第一行给出数字K,接着给出K行,每行第一个数字为N,接着给出N个数字,第i个数字表示坐标(i, Qi)是皇后,要求所有皇后不在同一行、同一列、同一对角线。

问给定的每行输入是否符合这个规则。

这道题开三个容器,标记各个行、列、斜边是否已经有皇后,接着对于新的输入判断容器值是否为True即可,有任意一个为true,说明行、列、斜边已经被占了。

判断斜边时,用下标和即可。因为在同一斜边上的元素的横纵下标之和肯定一样

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

int main(){
  int cnt;
  cin >> cnt;
  for(int i = 0; i < cnt; i++){
    int N;
    cin >> N;
    //定义存放行、列、斜(下标为行号+列号)的容器 
    vector<bool>   row(N + 1, false),
            col(N + 1, false),
            dig(2*(N+1),false);
    bool flag = false;  //false=>YES, true=>NO 
    for(int j = 0; j < N; j++){
      int n;
      cin >> n;
      if(row[n] || col[j] || dig[n + j] || flag){
        flag = true;
        continue; 
      }
      row[n] = col[j] = dig[n + j] = true;
    }
    if(flag) cout << "NO" << endl;
    else cout << "YES" << endl;
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1128 N Queens Puzzle
目前还没有评论,快来抢沙发吧~