PAT-A 真题- 1090. Highest Price in Supply Chain

发布于 / PAT-甲级 / 0 条评论

原题干:

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

这道题建一棵静态二叉树即可,然后对二叉树进行带层号的层序遍历,求出最大层号即可。

代码如下:

#include <iostream>
#include <vector>
#include <queue>
#include <cmath>
using namespace std;

vector<vector<int> > tree;
int n;
double p, r;

int max_layer = -1, max_layer_sum = 1;
void layerOrder(int root){
    typedef struct{int id, layer;} node;
    queue<node> Q;
    Q.push({root, 0});
    while(!Q.empty()){
        //取出队首元素
        node iter = Q.front();
        int id = iter.id, layer = iter.layer;
        Q.pop();
        //判断层级大小
        if(layer > max_layer){max_layer = layer, max_layer_sum = 0;}
        if(layer == max_layer){max_layer_sum++;}
        //将当前节点下一层级放入队列
        for(int i = 0; i < tree[id].size(); i++){
            Q.push({tree[id][i], layer + 1});
        }
    }
}

int main(){
    cin >> n >> p >> r;
    tree.resize(n);
    int root;
    for(int i = 0; i < n; i++){
        int supplier;
        cin >> supplier;
        if(supplier == -1){
            root = i;
            continue;
        }
        tree[supplier].push_back(i);
    }
    layerOrder(root);
    double price = pow(1+0.01*r, max_layer) * p;
    printf("%.2f %d\n", price, max_layer_sum);
    return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题- 1090. Highest Price in Supply Chain
目前还没有评论,快来抢沙发吧~