PAT-A 真题- 1006. Sign In and Sign Out

发布于 / PAT-甲级 / 0 条评论

原题干:

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意:给定所有人的进出时间,找到最早进入和最晚离开的人。

这道题可以使用类似UNIX时间戳的方法,将时间转化为数字,然后进行大小判断。

代码如下:

#include <iostream>
#include <string>
using namespace std;

int main(){
    int max_time = 0, min_time = 0x3fffffff;
    string max_id, min_id;
    int cnt;
    scanf("%d", &cnt);
    while(cnt--){
        int tmp_h, tmp_m, tmp_s;
        string tmp;
        cin >> tmp;
        scanf("%d:%d:%d", &tmp_h, &tmp_m, &tmp_s);
        if(((tmp_h*60*60) + (tmp_m*60) + (tmp_s)) < min_time){
            min_time = (tmp_h*60*60) + (tmp_m*60) + (tmp_s);
            min_id = tmp;
        }
        scanf("%d:%d:%d", &tmp_h, &tmp_m, &tmp_s);
        if(((tmp_h*60*60) + (tmp_m*60) + (tmp_s)) > max_time){
            max_time = (tmp_h*60*60) + (tmp_m*60) + (tmp_s);
            max_id = tmp;
        }
    }
    cout << min_id << " " << max_id << endl;
    return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题- 1006. Sign In and Sign Out
目前还没有评论,快来抢沙发吧~