PAT-A 真题 – 1028 List Sorting

发布于 / PAT-甲级 / 0 条评论

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

题目大意:Excel排序。第一行给出两个数字,第一个是记录数量,第二个是对第几列进行排序,接着给出记录,按照要求排序并输出。

代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
#define MAXN 100010
#define MAXS 9
using namespace std;

typedef struct {
  int id, score;
  char name[MAXS];
} node;

int C;
bool cmp(node a, node b){
  switch(C){
    case 1:
      return a.id < b.id;
      break;
    case 2:
      return (strcmp(a.name, b.name) == 0) ? a.id < b.id : (strcmp(a.name, b.name) < 0);
      break;
    case 3:
      return a.score == b.score ? a.id < b.id : a.score < b.score;
  }
}

int main(){
  node table[MAXN];
  int N;
  scanf("%d %d", &N, &C);
  for(int i = 0; i < N; i++){
    node t;
    scanf("%d %s %d", &t.id, &t.name, &t.score);
    table[i] = t;
  }
  sort(table, table + N, cmp);
  for(int i = 0; i < N; i++)
    printf("%06d %s %d\n", table[i].id, table[i].name, table[i].score);
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1028 List Sorting
目前还没有评论,快来抢沙发吧~