PAT-A 真题 – 1149 Dangerous Goods Packaging

发布于 / PAT-甲级 / 0 条评论

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: N (104), the number of pairs of incompatible goods, and M (100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] ... G[K]

where K (1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:

For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:

6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333

Sample Output:

No
Yes
Yes

题目大意:

物品运输时,有些物品不能放在一起,例如氧化剂和易燃物品。

给定两个数字:N和M

给定N对不能放在一起的东西,给M个查询,每个查询包含一大堆物品,判断这些物品能否放在一起。

这道题直接一个个查找会超时,最好的办法是列出表格,物品对应不能放在一起的列表,然后对于查询一个个遍历,判断能否放在一起。

代码如下:

#include <iostream>
#include <algorithm>
#include <map>
#include <vector>
using namespace std;

int main(){
  int input_cnt, query_cnt;
  map<int, vector<int> > table;
  cin >> input_cnt >> query_cnt;
  for(int i = 0; i < input_cnt; i++){
    int n, m;
    cin >> n >> m;
    table[n].push_back(m);
    table[m].push_back(n);
  }
  while(query_cnt--){
    int n;
    cin >> n;
    int fuck[100000] = {0};
    vector<int> goods(n);
    for(int i = 0; i < n; i++){
      cin >> goods[i];
      fuck[goods[i]] = 1;
    }
    bool ojbk = true;
    for(int i = 0; i < n; i++)
      for(int j = 0; j < table[goods[i]].size(); j++)
        if(fuck[ table[goods[i]][j] ] == 1)
          ojbk = false;
    if(ojbk)
      cout << "Yes" << endl;
    else cout << "No" << endl;
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1149 Dangerous Goods Packaging
目前还没有评论,快来抢沙发吧~