PAT-A 真题 – 1078 Hashing

发布于 / PAT-甲级 / 0 条评论

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (104) and N (MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

题目大意:哈希表问题,第一行给出哈希表大小和输入数据的个数,然后接下来给出输入的数据,将它们插入到哈希表,依次输出位置。

注意:使用正数平方探测法。如果题目所给哈希表大小不是质数,应该把哈希表大小调整为比题目所给的数字大的最小的质数。

这道题比较容易错的地方在于,1不是质数!!!如果哈希表大小为1,应调整为2。

代码:

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

bool isPrime(int n){
  if(n == 1) return false;
  if(n == 2) return true;
  for(int i = 2; i < n / 2 + 1; i++)
    if(n % i == 0) return false;
  return true;
}

int insert(vector<int> &v, int n){
  int h = n % v.size();
  for(int i = 0; i < v.size(); i++){
    int pos = (h + i * i) % v.size();
    if(v[pos] == -1){
      v[pos] = n;
      return pos;
    }
  }
  return -1;
}

int main(){
  int MSize, N;
  cin >> MSize >> N;
  while(!isPrime(MSize)) MSize++;
  vector<int> HashTable(MSize, -1);
  for(int i = 0; i < N; i++){
    if(i != 0) cout << ' ';
    int n;
    cin >> n;
    int p = insert(HashTable, n);
    if(p == -1) cout << '-';
    else cout << p;
  }
  cout << endl;
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1078 Hashing
目前还没有评论,快来抢沙发吧~