PAT-A 真题 – 1041 Be Unique

发布于 / PAT-甲级 / 0 条评论

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

题目大意:火星人的赌博游戏

给定第一个数字N,接着给出N个数据,这N个数据中,必须是第一个出现并且和别人没有说一样的数字才算影,有赢的人,输出他说的数字,如果没有赢的,输出None。

很简单,不做详细解释了

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

int main(){
  int Exist[10000] = {0};
  int cnt;
  cin >> cnt;
  vector<int> V;
  for(int i = 0; i < cnt; i++){
    int num;
    cin >> num;
    Exist[num]++;  //记录出现次数 
    V.push_back(num);
  }
  for(auto i : V){
    if(Exist[i] == 1){
      cout << i << endl;
      return 0;
    }
  }
  cout << "None" << endl;
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1041 Be Unique
目前还没有评论,快来抢沙发吧~