PAT-A 真题 – 1075 PAT Judge

发布于 / PAT-甲级 / 0 条评论

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (104), the total number of users, K (5), the total number of problems, and M (105), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either 1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

题目大意:模仿pat的评测系统,输入学生的每次提交信息,要求输出成绩单。

输入的格式为,第一行:学生个数、题目个数、提交个数;第二行为每道题的满分分数,之后给出学生提交的信息,每行第一个是考号,第二个是题目,第三个是得分。-1分表示没有通过编译。

定义最终得分为得分最高的一次。

要求输出按照成绩降序输出,如果有两个学生的总分数相同,按照满分题目的个数降序排序。如果依然相同,按照考号升序排序。如果学生没有任何提交或没有任何一道题通过了编译,就不输出。

这道题逻辑比较复杂,按照规范的方式进行模拟,多调试几次不会出错。

要注意的是,没有任何题通过编译的才不输出,如果有通过编译的但是得了0分的,要正常输出!

#include <iostream>
#include <bits/stdc++.h>
using namespace std;

typedef struct{
  int id;
  int all_score;
  int full_score_cnt;
  bool is_pass_compiler; 
  vector<int> each_score;
} node;

bool cmp(node a, node b){
  if(a.all_score != b.all_score)
    return a.all_score > b.all_score; //分数大的排在前面
  if(a.full_score_cnt != b.full_score_cnt)
    return a.full_score_cnt > b.full_score_cnt;  //满分多的排在前面
  return a.id < b.id;      //都一样,那就字典序吧~ 
}

int main(){
  int scnt, qcnt, icnt;
  scanf("%d %d %d", &scnt, &qcnt, &icnt);
  vector<int> ques_full_score(qcnt + 1);  //存储分数 
  for(int i = 1; i <= qcnt; i++)  //读取满分分数 
    scanf("%d", &ques_full_score[i]);
  vector<node> L(scnt + 1);    //定义存储成绩单的容器 
  for(int i = 0; i < icnt; i++){  //读取提交信息 
    int stu_id, ques_id, ques_score;
    scanf("%d %d %d", &stu_id, &ques_id, &ques_score); 
    if(L[stu_id].each_score.size() == 0){  //该单元尚未初始化 
      L[stu_id].each_score.resize(qcnt + 1, -1);  //-1表示没有作答
      L[stu_id].id = stu_id;
      L[stu_id].all_score = 0;
      L[stu_id].full_score_cnt = 0;
      L[stu_id].is_pass_compiler = false;
    }
    if(ques_score != -1) L[stu_id].is_pass_compiler = true;  //通过编译 
    else ques_score = 0;
    L[stu_id].each_score[ques_id] = max(L[stu_id].each_score[ques_id], ques_score); 
  }
  for(auto it = L.begin(); it != L.end(); it++){  //遍历每一个学生 
    if((*it).each_score.size() == 0)  //说明这个人没有提交
      continue;
    int all_score = 0, full_score_cnt = 0;
    for(int i = 1; i <= qcnt; i++){  //把这个同学的每一道题都遍历一遍 
      if((*it).each_score[i] == ques_full_score[i])  //本题满分
        full_score_cnt++;
      if((*it).each_score[i] != -1)
        all_score += (*it).each_score[i];  //累计分数 
    }
    (*it).all_score = all_score;
    (*it).full_score_cnt = full_score_cnt;
  }
  sort(L.begin(), L.end(), cmp);
  int real_cnt = 0, rank = 0, last_score = -1;
  for(auto it : L){
    if(it.is_pass_compiler == false)
      continue;  //没有有效提交 
    real_cnt++;
    if(it.all_score != last_score){
      last_score = it.all_score;
      rank = real_cnt;
    }
    printf("%d %05d %d", rank, it.id, it.all_score);
    for(int i = 1; i <= qcnt; i++)
      if(it.each_score[i] != -1) printf(" %d", it.each_score[i]);
      else printf(" -");
    printf("\n");
  }
  return 0;
}

转载原创文章请注明,转载自: 斐斐のBlog » PAT-A 真题 – 1075 PAT Judge
目前还没有评论,快来抢沙发吧~